PDA

View Full Version : .17hmr Misfire.


dale7637
04-24-2009, 04:31 PM
Hey guys. I need some help. I have a savage 93r17 in 17hmr. The gun has been great, but developed a misfire recently. It is not an ammo problem. The gun will fire once out of every 2-5 pulls of the trigger. Its getting old. I sent the gun back to the place i bought it. They simply slammed a different bolt in it and sent it back. That didnt fix things, so i took it to a gunsmith. He said that he adjusted the headspacing, but still no fix. I am getting fed up, and worst of all it is now off of warranty. Any ideas on what to do?

IR_mike
04-24-2009, 10:14 PM
Is it a accutrigger model? If so it might be tuned down too low, Mine did that from factory.

Dean2
04-25-2009, 08:20 AM
Try IR Mike's idea re set the trigger a little firmer. If that doesn't work and even if it does, check the bolt to sear engaement. It sounds as though it isn't releasing cleanly aad is dragging (slowing) the fall of the firing pin. You should also dissasemble bolt and see if it is gunked up inside, see link to a good website on how. Mine had lots of heavy grease from factory. The link also helps in how to polish the bolt and smooth the operation. Hope this helps.

http://www.rimfirecentral.com/forums/showthread.php?t=78552&page=4

Sir Rollo
04-25-2009, 12:00 PM
Funny thing with the accu-trigger I have noticed with my savage 17 HMR is that if the trigger is rubbed before the safe part is fully depressed, it will just click. I learned this while shooting in cold weather, and trying to use a pair of gloves. The deerskin made my finger fat enough to depress the trigger before the safe catch was fully released.

gibbs
04-25-2009, 01:39 PM
Thats good information. My MKII did that one time and i had no idea why. It went "click" just like normal, but there was absolutely no dent on the rim at all. If it happens again, I will know why. Thanks. My 93R17 has never done that to date.